Williams College - Partial unavailability of Airtable 2026-02-12 – Incident details

Experiencing partially degraded performance

Partial unavailability of Airtable 2026-02-12

Resolved
Partial outage
Started 5 months agoLasted about 2 hours

Affected

Airtable → Airtable Service

Operational from 5:40 AM to 5:40 AM, Partial outage from 5:40 AM to 7:49 AM

Updates
  • Resolved
    Resolved

    We have mitigated the issue as of 10:22 PM PST and all site functionality except billing management should now be working. We are separately working on restoring billing functionality.

  • Update
    Update

    We have found the root cause and applied a mitigation that restores most base functionality such as read/writes as of 9:45PM PST.  However, certain functionality like adding collaborators/shares or creating/deleting applications are still unavailable. We're actively working on restoring that functionality.

  • Investigating
    Investigating

    We are currently investigating partial unavailability of Airtable