Williams College - Airtable service interruption – Incident details

Experiencing partially degraded performance

Airtable service interruption

Resolved
Major outage
Started 5 months agoLasted about 7 hours

Affected

Airtable → Airtable Service

Operational from 6:44 PM to 6:44 PM, Major outage from 6:44 PM to 11:16 PM, Partial outage from 11:16 PM to 1:20 AM, Degraded performance from 1:20 AM to 1:27 AM

Updates
  • Resolved
    Resolved

    Our recovery is complete, and Airtable's service is back to normal.

  • Monitoring
    Monitoring

    We have completed the recovery of the primary issue. The vast majority of Airtable functionality is restored. There may be some residual slowness and errors.

  • Update
    Update

    Many Airtable bases are now reachable. Some bases and some Airtable features are still broken. We continue to work towards full recovery.

  • Update
    Update

    Recovery is continuing. We are on a path to full recovery and are exploring ways to expedite this.

  • Update
    Update

    We have begun recovery. Our remediation is still in progress. Some Airtable bases are reachable, and the rest will come online soon.

  • Identified
    Identified

    The issue has been identified and a fix is being implemented.

  • Investigating
    Investigating

    We are aware of an issue impact the availability of the Airtable service. Our engineers are engaged and we will post status updates here.